User talk:Yaossg


the new front page

Looks good!

Interesting thought to group filesystem under I/O. Not sure I agree, but not sure I disagree either.

I think some of the General Utilities aren't so notable as to be put up front (type_index for example).

"Elementary string" implies it's some sort of a string type. Call that "string conversions" or even better, to_chars -- from_chars"

Also, "utilities" is a bad word to use in naming anything. I know the standard uses it, but we can do better: "Memory utilities" should probably be "Smart pointers and allocators". "Time utilities" can be "Date and time library" (or just "date and time")

(just a few things that jumped out so far..)

thanks for checking. I grouped filesystem under I/O beacaue standard did it.I know it seems to be a little strange, so we need more discussions. other suggestions will be applied to page.
We don't need to follow the standard's idiosyncratic grouping - or for that matter its stubborn refusal to add new library clauses. Having 20 subclauses under Clause 23 is ridiculous. T. Canens (talk) 12:35, 18 December 2017 (PST)
It looks nice now, any advice or just apply to real page now?
Looks good to me. TC? --Cubbi (talk) 04:07, 22 December 2017 (PST)
A few things:
  1. I'd move "language support library" and children to where string is currently, and move string to end of col 2. IMO it makes more sense for "language support" to come directly after "language".
  2. <compare> should be under language support. The comparison category types in there need tight integration with the compiler.
  3. I'm not seeing the need to call out <ratio> and integer_sequence. These are more on the niche side.
  4. We should come up with a good name for the group of <utility> functions (move/forward/swap/exchange/as_const etc.) and link it.
  5. I'd move localization to be right before I/O. iostreams' coupling with locales is legendary.
  6. I'd still like to see Filesystem split out from I/O. Yes, the standard puts it under Clause 30. I think the standard is crazy. T. Canens (talk) 05:05, 22 December 2017 (PST)
  1. history problems, I'd solve it later.
  2. that's right, I'd solve it later
  3. the name of them is hard to think. names like "utility functions" may be one of the best or the worst names.
  4. my order was following the standard. but it seems to be a better ways like yours
  5. crazy standard, take it right now.
sorry, it became ugly again, I feel terrible.
Let's move containers to below strings and flesh it out with a few frequently used containers (e.g., vector, array, map/unordered_map since that's a beginner favorite I think). That should fill up the middle column, especially if we add a line for "utility functions". T. Canens (talk) 10:17, 22 December 2017 (PST)
I think maybe it's time to apply to the real main page. Yaossg (talk) 21:42, 31 December 2017 (PST)

I made some small adjustments that I think improve the page's cleanness and consistency. If you're happy with them, I'd agree that the page is good to be deployed. I do wish we could come up with a better name for swap/move/forward/exchange than "utility functions"; they all share the property of "moving" or adjusting the "movement" of objects, so I was thinking maybe "move helpers" or "movers"? --Ybab321 (talk) 11:43, 3 January 2018 (PST)

'movers' can't be worse. 'move helpers' should be a longer name. I'm waiting for a better name.
That's fair. Regarding 'NUL' vs 'null'; 'NUL' is just an abbreviation, the proper name of the character is 'null' [[1]], the standard also uses the term 'null-terminated byte string', as do the three linked-to pages. --Ybab321 (talk) 02:48, 4 January 2018 (PST)

So when's the big roll-out? I think it's at the point where tweaks can be applied later, as needed. Anyone else? --Cubbi (talk) 15:06, 19 January 2018 (PST)

OK with me. T. Canens (talk) 15:32, 19 January 2018 (PST)
OK, I'll apply later Yaossg (talk) 16:16, 19 January 2018 (PST)

ASCII in the new front page

Regarding "ASCII not part of C++" - that is true (and it is not part of C either), but we do have c/language/ascii as well as cpp/language/ascii for historic reasons, and they get plenty of hits (personally, I'd love to see them get to the top of google result page instead of the misleading which lists some unnamed ancient codepage as "Extended ASCII Codes"). I don't mind removing ascii table link from the front page, to be honest, but there should be a link to it somewhere. Perhaps from cpp/links#Related_standards? --Cubbi (talk) 11:20, 26 December 2017 (PST)

that's fine. shall we move them to better place(like cpp/ascii or just ascii) then add a redirect?